Darkkefka

Version 9 bug report (report all problems here)

283 posts in this topic

4 hours ago, Incubus_prince said:

Hello I'm stuck @ the rematch with Axem Red the battle goes smoothly until mack and Bowyer appear then the battle menu glitches and any further move freezes the game. Is this a known glitch or an emulator failure. 

I believe that was an issue with the initial release of normal mode back when it was still called the content mode.

It should be fixed in the latest update.

0

Share this post


Link to post
Share on other sites
18 hours ago, Doomsday31415 said:

 

18 hours ago, Doomsday31415 said:

 

18 hours ago, Doomsday31415 said:

I believe that was an issue with the initial release of normal mode back when it was still called the content mode.

It should be fixed in the latest Ye

(Sorry for triple quoting) I solved the issue by getting the latest version however after smithy the game froze on the star screen (I was on PAL) and trying to correct the issue the game erased my save file I spent all day yesterday getting back to where I was I dont know what to do now I just wanted the post game content. 

0

Share this post


Link to post
Share on other sites
1 hour ago, Incubus_prince said:

(Sorry for triple quoting) I solved the issue by getting the latest version however after smithy the game froze on the star screen (I was on PAL) and trying to correct the issue the game erased my save file I spent all day yesterday getting back to where I was I dont know what to do now I just wanted the post game content. 

You must use the patch on the US version of the game, otherwise it won't work.

0

Share this post


Link to post
Share on other sites

Sorry I wasnt clear I'm was using US rom from but its known to freeze @ johnny Jones & the Axem ranger stars was told to click Pal option (using zsnes) on my emulator to medigate this and it worked so  I left the option on and will the finale just froze. I'll give it another go this weekend. Thanks for your info.

0

Share this post


Link to post
Share on other sites
12 minutes ago, Incubus_prince said:

Sorry I wasnt clear I'm was using US rom from but its known to freeze @ johnny Jones & the Axem ranger stars was told to click Pal option (using zsnes) on my emulator to medigate this and it worked so  I left the option on and will the finale just froze. I'll give it another go this weekend. Thanks for your info.

You must use Snes9X 1.53+.  ZSNES is a garbage emulator that doesn't emulate SMRPG properly.

1

Share this post


Link to post
Share on other sites

Hi, recently beaten all I could find in armageddon v9. Uh just kinda dropping a few notes of what i noticed through m y playthrough. Overall I really enjoyed the experience of playing this mod of the game! There are a few fights before approaching valentina (nimbus land) whilst in nimbus castle (whatever its called) that there were a few video glitches mid fight... nothing too serious i guess. One problem i did have was during the 'trial boss rush' that rosalina gives you there were several fights that I could not use peach's morning star move just because of some sort of lag. (Couldn't time the move properly because of it). I have a really powerful computer so just figured i'd throw this out there. Thanks darkkefla for bringing back the first rpg of my childhood back to life!

0

Share this post


Link to post
Share on other sites
3 hours ago, annh said:

Hi, recently beaten all I could find in armageddon v9. Uh just kinda dropping a few notes of what i noticed through m y playthrough. Overall I really enjoyed the experience of playing this mod of the game! There are a few fights before approaching valentina (nimbus land) whilst in nimbus castle (whatever its called) that there were a few video glitches mid fight... nothing too serious i guess. One problem i did have was during the 'trial boss rush' that rosalina gives you there were several fights that I could not use peach's morning star move just because of some sort of lag. (Couldn't time the move properly because of it). I have a really powerful computer so just figured i'd throw this out there. Thanks darkkefla for bringing back the first rpg of my childhood back to life!

Glad you enjoyed it!  This is the first I've heard of lag in the trial mode... what fights did it happen?

0

Share this post


Link to post
Share on other sites

Yeah I loved this. Like maybe 20-22 years ago at the young age of 8 i found smrpg in my cousins snes and fell in love with the game. Having a lot of experience with ff7 through ffx on playstation I really felt this mod is just a beauty!

I went back and rebeat the trial mode. The explosion that occurs with peach's morning star move seems to expand at different rates of speed in different fights. I think its partially maybe just me... and being specific with that slight delay once the explosion is fully expanded can kinda mess with ya... but if you get a chance to try the dodo, valentina, and birdo i think it seemed to be the one i struggled using the morning star.

0

Share this post


Link to post
Share on other sites

I'm really unsure if I 'patched' or placed the ips file correctly or not. After doing some reading in 'normal' mode you don't get repeat items like the galaxy ring. But after beating the trial mode I indeed got another galaxy ring. What little research i've done all I did was took the original smrpg rom and placed the new (normal) ips file beside it and renamed the (normal) ips file as the exact same name as the original rom...

0

Share this post


Link to post
Share on other sites
37 minutes ago, annh said:

I'm really unsure if I 'patched' or placed the ips file correctly or not. After doing some reading in 'normal' mode you don't get repeat items like the galaxy ring. But after beating the trial mode I indeed got another galaxy ring. What little research i've done all I did was took the original smrpg rom and placed the new (normal) ips file beside it and renamed the (normal) ips file as the exact same name as the original rom...

Normal mode is blue.  Content is green.

0

Share this post


Link to post
Share on other sites

Toadstool's Ultima special is broken. It did a loop of the animation forever and had to load state.

0

Share this post


Link to post
Share on other sites
25 minutes ago, IcieJiraceon said:

Toadstool's Ultima special is broken. It did a loop of the animation forever and had to load state.

Considering neither Toadstool nor Ultima is in v9, I'm guessing something went wrong when patching.

0

Share this post


Link to post
Share on other sites
17 minutes ago, IcieJiraceon said:

I am unable to move upon entering Jonathon's ship, softlocking me.

See previous statement.  Also, are you using Snes9X 1.53+?

0

Share this post


Link to post
Share on other sites
47 minutes ago, Doomsday31415 said:

See previous statement.  Also, are you using Snes9X 1.53+?

Yes, I am using Snes9x 1.53

Edited by IcieJiraceon
typo
0

Share this post


Link to post
Share on other sites

Does bad checksum mean something went wrong when patching? I went and got another download copy to patch and that happened.

0

Share this post


Link to post
Share on other sites
1 hour ago, IcieJiraceon said:

Does bad checksum mean something went wrong when patching? I went and got another download copy to patch and that happened.

No, that's normal.

0

Share this post


Link to post
Share on other sites
Just now, IcieJiraceon said:

Is there a reason why most of the item boxes are empty?

Did you completely delete your save file and start over?

0

Share this post


Link to post
Share on other sites

I found a glitch in the doom cake boss where you're unable to target it, but you're able to target the special tab's text and character text?

0

Share this post


Link to post
Share on other sites
7 minutes ago, IcieJiraceon said:

I found a glitch in the doom cake boss where you're unable to target it, but you're able to target the special tab's text and character text?

I'm going to go out on a limb and say it's the same problem as the other issues you've seen.  How are you patching the rom?

0

Share this post


Link to post
Share on other sites
8 minutes ago, IcieJiraceon said:

I'm using Lunar IPS to patch the rom.

Well, no issue there then...

Are you using the 1996 US rom?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now